Maven引用net-sf-json-lib报错

Maven引用net-sf-json-lib报错

maven项目pom文件引用json这个包,报错误:Missing artifact net.sf.json-lib:json-lib:jar:2.4:compile

错误配置:

1
2
3
4
5
<dependency>
<groupId>net.sf.json-lib</groupId>
<artifactId>json-lib</artifactId>
<version>2.4</version>
</dependency>

json-lib是需要区分jdk版本的,pom.xml中的配置应加上标签classifier指定jdk版本,如用jdk15。

正确配置:

1
2
3
4
5
6
<dependency>
<groupId>net.sf.json-lib</groupId>
<artifactId>json-lib</artifactId>
<version>2.4</version>
<classifier>jdk15</classifier><!--指定jdk版本-->
</dependency>
-------------已经触及底线 感谢您的阅读-------------

本文标题:Maven引用net-sf-json-lib报错

文章作者:趙小傑~~

发布时间:2018年07月01日 - 23:20:40

最后更新:2019年09月16日 - 19:33:47

原始链接:https://cnsyear.com/posts/398d4621.html

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。

0%